Linkerd proxies are not installed on new pods launched

Hi … we are trying to test linkerd for a new data refinery we are setting up on cloud. I am able to install and make it work using the reference documentation provided for the pods which are always on. However my new pods which are launched by kubernetes based on some request don’t have the proxy by default. How to enable linkerd for the pods which will be generated on the go and will be killed once job is done ?

Hi @Manish can you describe more about how the pods are created?

If they exist in the same namespace, then you can add the linkerd.io/inject: enabled annotation to the namespace and any pod in that namespace will be injected with the proxy when it is created.

If you’ve got a more dynamic mechanism for creating the pods, then please join us on Linkerd slack so we can talk through it in real time.

Charles

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.