Https://discourse.linkerd.io/t/flavors-of-kubernetes/53


#1

Hi @esbie,

I am following steps mentioned at https://buoyant.io/2017/04/19/a-service-mesh-for-kubernetes-part-ix-grpc-for-fun-and-profit/

The quoted steps below are not giving the expected results.
Continuing the discussion from Flavors of Kubernetes:

In addition, assuming OUTGOING_PORT and L5D_INGRESS_LB are environment variable, I set them as mentioned below:

setenv OUTGOING_PORT kubectl get svc l5d -o jsonpath='{.spec.ports[?(@.name=="outgoing")].nodePort}'
setenv L5D_INGRESS_LB http://minikube ip:$OUTGOING_PORT

I have echo’d both the environment to double check. Its fine.
Could you please elaborate the http_proxy bit?

Also. tried “open http://$(minikube ip):$ADMIN_PORT” with hardcoded values. However did not get the expected result.

I am using minikube on MacOS.

Please let me know if you need further info to understand / elaborate the problem.

Thanks,
Dheeraj


#2

http_proxy is what is routing traffic through linkerd. from the curl man pages:

ENVIRONMENT
The environment variables can be specified in lower case or upper case. The lower case version has precedence. http_proxy is an exception as it is only
available in lower case.
Using an environment variable to set the proxy has the same effect as using the -x, --proxy option.

       http_proxy [protocol://]<host>[:port]
              Sets the proxy server to use for HTTP.

If you didn’t receive the expected result for “open http://$(minikube ip):$ADMIN_PORT”, what did you receive or what happens? Is the value of $ADMIN_PORT set?


#3

Hi @esbie,

Thanks for the response.
I retired the steps using bash and it worked. Please note that earlier I was using tcsh.

Many thanks,
Dheeraj


#4

Glad to hear it’s working!