How Can i configure linkerd to wotk with zipkin through http instead of scribe

Hi , i’m running linkerd on mesos and want to config it to pass the traces to zipkin.
So i found in your documentation that you use scribe with port 9410 instead of Http(9411).
on the first look , it working fine , but there is a lot of issue with scribe that zipkin know about and it not stable at all( after X time we stop see traces)

So i googled it and i found there is another package that you create https://github.com/linkerd/linkerd-zipkin and here you talking about an option to use http instead of scribe.

my question is how should we using this one? am i should replace it with my existing linkerd instances? or it a level between linkerd and zipkin?

is there a good guideline that we can use in order to configure it to work as expected?

And one more question that is not related to the first one
When zipkin is failed and back up again , we have to restart the linkerd nodes in order to get the new traces, it look like linkerd marked the zipkin as down and stop sending data to it, is there an option to change this behaviour ?

we are using this docker: buoyantio/linkerd:0.9.1

For the second question: you can set failure accrual to ‘none’ to stop linkerd from marking nodes as dead https://linkerd.io/config/0.9.1/linkerd/index.html#failure-accrual

https://github.com/linkerd/linkerd-zipkin is a linkerd plugin that you can use in your existing linkerd instances.