gRPC Ingress routing

Hello,
I’m using Linkerd with kubernetes cluster 1.7. I’ve configured linkerd as bellow:

# HTTP/2 Ingress Controller listening on port 8080
- protocol: h2
  experimental: true
  label: h2-k8s-ing
  servers:
    - port: 8080
      ip: 0.0.0.0
      clearContext: true
  identifier:
    kind: io.l5d.ingress
  dtab: /svc => /#/io.l5d.k8s

When I want to change ingress with same port but pointing to another container I receive : no ingress rules to match

I’ve to delete l5d POD, to force reaping.

Linkerd version: 1.3.1rc1

Hi @jsenon!
Can you describe how it is you change ingress and what the before/after of your ingress resources look like? Thanks!

Hi @esbie, we change

apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: matcher
  annotations:
    kubernetes.io/ingress.class: "linkerd"
spec:
  backend:
    serviceName: matcher
    servicePort: 8080

and replace by

apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: map-service
  annotations:
    kubernetes.io/ingress.class: "linkerd"
spec:
  backend:
    serviceName: map-service
    servicePort: 8080

I’ve to reproduce bug to send more logs

Hi @jsenon. Thanks for the additional detail, it helps. What you are seeing is definitely not expected. Can you turn on debug logging and send us the linkerd log output? You can do that by adding -log.level=DEBUG to your linkerd startup command.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.