Distributed tracing

Hi,

I implemented tracing for my app, but I can’t see linkerd traces.
I used the collector and jaeger provided by the docs, I can see my own traces but no trace of linkerd’s.

I read that the collector needs to be meshed but it seems it is not, even though I used the collector provided by linkerd.

What could have gone wrong?

Hi @vise,

Can you share the configuration with us?

You may need to annotate the namespace where the tracing deployments are running with the linkerd.io/inject: enabled annotation. You can find the documentation here.

Alternatively, you can use the [linkerd inject](https://linkerd.io/2/reference/cli/inject/) command on each of the deployments, but I recommend annotating the namespace as described above in this case.

Charles

I found the reason.
I was deploying jaeger and the collector before linkerd.
I guess linkerd doesn’t apply to existing deployment with inject annotations unless explicitely injected? (it would make sense, and it’s a expected behaviour, I’m asking just to confirm)

@vise, you’re right, the deployments must be restarted in order for the proxy-injector mutatingwebhookcontroller to detect that the deployment has been annotated.