Cannot run the Grafana in the linkerd-examples

When I run the linkerd-examples/add-steps, I can see the linkerd admin page running normally, but the Grafana page of the port 3000 didn’t show any cool graphs, just like it cannot get any data. So should I do something else to configure the data source or the dashbord? I just use the source code clone from https://github.com/linkerd/linkerd-examples.git and follow the guidance in README.md under the add-steps directory.

Hi @Blanchedingding. A few questions:

  1. What OS are you running?

  2. What Docker installation?

  3. What does docker-compose logs give you?

  4. What does :3000/datasources/edit/1 look like? Can you hit Save & Test? We expect this:

  5. What does :9090/targets look like? We expect this:

First, thank you very much!!!

  1. The OS is CentOS7

  2. The output of “docker --version” is:
    Docker version is 17.07.0-ce, build 8784753

  3. The docker-compose logs gives following:

  4. The save&test is success

  1. the :9090/targets looks like:

@Blanchedingding That last screenshot of :9090/targets does not include any reference to slow_cooker. Is the screenshot simply cut off, or is slow_cooker not working correctly?

en, I think it’s working correctly:

Ok, looks like everything is working as expected. Possibly naive question: Did you wait 15 seconds on the Grafana dashboard for stats to appear?

Something else to try, verify the stats are available in Prometheus by browsing to:

:9090/graph?g0.range_input=1h&g0.expr=rate(requests%7Binstance%3D%22linkerd_slow_cooker%3A8505%22%7D%5B1m%5D)&g0.tab=1&g1.range_input=1h&g1.expr=rate(requests%7Bjob%3D%22linkerd_apps%22%7D%5B1m%5D)&g1.tab=1&g2.range_input=1h&g2.expr=rate(requests%7Bjob%3D%22baseline_apps%22%7D%5B1m%5D)&g2.tab=1

I’m sure that I waited for more than 15 seconds, but I opened the url you posted, I got:


Obviously, it doesn’t work to get any data. I never have used the Prometheus previously, so do you know any possible reasons to cause such strange situation?

So it looks like all the apps are running, Prometheus is able to connect to them, but is not reporting any metrics.

After running the setup for several minutes, can you manually gather metrics data for the apps:

curl linkerd:9990/admin/metrics/prometheus
curl baseline_slow_cooker:8505/metrics
curl linkerd_slow_cooker:8505/metrics
curl baseline_app1:8510/metrics
curl linkerd_app1:8510/metrics

Oh, I run another example today, and found it can get data but just cannot draw the graph?
1

When I moved my mouse above the graph, the performance data showed. :joy:

Sounds like Grafana is doing something weird. You could try another browser as a sanity check, and then maybe updating the version of Grafana?

OK, I think it’s the problem of the server’s performace or config? I changed another server and waited for some time and the graph showed! Although I don’t know clearly why :sweat_smile:Thank all of you !

Glad to hear it’s working now!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.